const regex = new RegExp('\\beat food\\b', 'gm')
const str = `eat food and she eat food so he can eat food`;
const subst = `food eat`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);