// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\beat food\b").unwrap();
let string = "eat food and she eat food so he can eat food";
let substitution = "food eat";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}