$re = '/\beat food\b/m';
$str = 'eat food and she eat food so he can eat food';
$subst = "food eat";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;