re = /\beat food\b/m
str = 'eat food and she eat food so he can eat food'
subst = 'food eat'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result