#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\–.+"
Local $sString = "– Ne soyez donc pas si strict, Josef. Elle est encore un bébé. " & @CRLF & _
"– Précisément, c'est à cet âge qu'il faut leur inculquer les bonnes manières. " & @CRLF & _
"Nadia fit la moue et ordonna à ses enfants encore attablés : " & @CRLF & _
"– Samia ! Soliman ! Allez, aidez-moi à débarrasser. " & @CRLF & _
"Sans l'écart d'âge, la mère et la fille auraient pu passer pour deux soeurs : mêmes " & @CRLF & _
"yeux noirs en amande, même chevelure de jais, mêmes visages ronds. Mêmes lèvres " & @CRLF & _
"charnues. Le garçon, lui, ressemblait plutôt à son père avec déjà, à seize ans, une légère " & @CRLF & _
"tendance à l'embonpoint. " & @CRLF & _
"Marcus adressa un signe d'encouragement à Irina. " & @CRLF & _
"– Toi aussi, tu peux aider, ma chérie. Vas-y. " & @CRLF & _
"– Oh ! Mais laissez-la donc tranquille, gronda Nadia. Vous êtes un vrai tyran. " & @CRLF & _
"Saisissant la fillette par la main, elle l'entraîna avec elle."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")