$re = '/\–.+/m';
$str = '– Ne soyez donc pas si strict, Josef. Elle est encore un bébé.
– Précisément, c\'est à cet âge qu\'il faut leur inculquer les bonnes manières.
Nadia fit la moue et ordonna à ses enfants encore attablés :
– Samia ! Soliman ! Allez, aidez-moi à débarrasser.
Sans l\'écart d\'âge, la mère et la fille auraient pu passer pour deux soeurs : mêmes
yeux noirs en amande, même chevelure de jais, mêmes visages ronds. Mêmes lèvres
charnues. Le garçon, lui, ressemblait plutôt à son père avec déjà, à seize ans, une légère
tendance à l\'embonpoint.
Marcus adressa un signe d\'encouragement à Irina.
– Toi aussi, tu peux aider, ma chérie. Vas-y.
– Oh ! Mais laissez-la donc tranquille, gronda Nadia. Vous êtes un vrai tyran.
Saisissant la fillette par la main, elle l\'entraîna avec elle.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);