import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\–.+";
final String string = "– Ne soyez donc pas si strict, Josef. Elle est encore un bébé. \n"
+ "– Précisément, c'est à cet âge qu'il faut leur inculquer les bonnes manières. \n"
+ "Nadia fit la moue et ordonna à ses enfants encore attablés : \n"
+ "– Samia ! Soliman ! Allez, aidez-moi à débarrasser. \n"
+ "Sans l'écart d'âge, la mère et la fille auraient pu passer pour deux soeurs : mêmes \n"
+ "yeux noirs en amande, même chevelure de jais, mêmes visages ronds. Mêmes lèvres \n"
+ "charnues. Le garçon, lui, ressemblait plutôt à son père avec déjà, à seize ans, une légère \n"
+ "tendance à l'embonpoint. \n"
+ "Marcus adressa un signe d'encouragement à Irina. \n"
+ "– Toi aussi, tu peux aider, ma chérie. Vas-y. \n"
+ "– Oh ! Mais laissez-la donc tranquille, gronda Nadia. Vous êtes un vrai tyran. \n"
+ "Saisissant la fillette par la main, elle l'entraîna avec elle.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}