use strict;
my $str = '– Ne soyez donc pas si strict, Josef. Elle est encore un bébé.
– Précisément, c\'est à cet âge qu\'il faut leur inculquer les bonnes manières.
Nadia fit la moue et ordonna à ses enfants encore attablés :
– Samia ! Soliman ! Allez, aidez-moi à débarrasser.
Sans l\'écart d\'âge, la mère et la fille auraient pu passer pour deux soeurs : mêmes
yeux noirs en amande, même chevelure de jais, mêmes visages ronds. Mêmes lèvres
charnues. Le garçon, lui, ressemblait plutôt à son père avec déjà, à seize ans, une légère
tendance à l\'embonpoint.
Marcus adressa un signe d\'encouragement à Irina.
– Toi aussi, tu peux aider, ma chérie. Vas-y.
– Oh ! Mais laissez-la donc tranquille, gronda Nadia. Vous êtes un vrai tyran.
Saisissant la fillette par la main, elle l\'entraîna avec elle.';
my $regex = qr/\–.+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}