import re
regex = re.compile(r"\–.+", flags=re.MULTILINE)
test_str = ("– Ne soyez donc pas si strict, Josef. Elle est encore un bébé. \n"
"– Précisément, c'est à cet âge qu'il faut leur inculquer les bonnes manières. \n"
"Nadia fit la moue et ordonna à ses enfants encore attablés : \n"
"– Samia ! Soliman ! Allez, aidez-moi à débarrasser. \n"
"Sans l'écart d'âge, la mère et la fille auraient pu passer pour deux soeurs : mêmes \n"
"yeux noirs en amande, même chevelure de jais, mêmes visages ronds. Mêmes lèvres \n"
"charnues. Le garçon, lui, ressemblait plutôt à son père avec déjà, à seize ans, une légère \n"
"tendance à l'embonpoint. \n"
"Marcus adressa un signe d'encouragement à Irina. \n"
"– Toi aussi, tu peux aider, ma chérie. Vas-y. \n"
"– Oh ! Mais laissez-la donc tranquille, gronda Nadia. Vous êtes un vrai tyran. \n"
"Saisissant la fillette par la main, elle l'entraîna avec elle.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")