using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s(?:[^'""/\s><]+?)[\s/>])|(?:\S+(?:\s*=\s*(?:(?:(['""])[\s\S]*?\1|([^\s>]+))|(?:[^'""\s>]+))))";
string input = @" <div
blah lorem
foo-bar
multi-line=""
foo
bar
""
bar="" asdf""
bar= zxcv
foo=asdf
aa=df-bar=()
a-b=df-b""ar=()
ac=df""-bar=()
ad=df-bar=()
></div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}