const regex = /(?:\s(?:[^'"/\s><]+?)[\s/>])|(?:\S+(?:\s*=\s*(?:(?:(['"])[\s\S]*?\1|([^\s>]+))|(?:[^'"\s>]+))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s(?:[^\'"\/\\s><]+?)[\\s\/>])|(?:\\S+(?:\\s*=\\s*(?:(?:([\'"])[\\s\\S]*?\\1|([^\\s>]+))|(?:[^\'"\\s>]+))))', 'g')
const str = ` <div
blah lorem
foo-bar
multi-line="
foo
bar
"
bar=" asdf"
bar= zxcv
foo=asdf
aa=df-bar=()
a-b=df-b"ar=()
ac=df"-bar=()
ad=df-bar=()
></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}