re = /(?:\s(?:[^'"\/\s><]+?)[\s\/>])|(?:\S+(?:\s*=\s*(?:(?:(['"])[\s\S]*?\1|([^\s>]+))|(?:[^'"\s>]+))))/
str = ' <div
blah lorem
foo-bar
multi-line="
foo
bar
"
bar=" asdf"
bar= zxcv
foo=asdf
aa=df-bar=()
a-b=df-b"ar=()
ac=df"-bar=()
ad=df-bar=()
></div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end