import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s(?:[^'\"/\\s><]+?)[\\s/>])|(?:\\S+(?:\\s*=\\s*(?:(?:(['\"])[\\s\\S]*?\\1|([^\\s>]+))|(?:[^'\"\\s>]+))))";
final String string = " <div\n"
+ " blah lorem\n"
+ " foo-bar\n"
+ " multi-line=\"\n"
+ " foo\n"
+ " bar\n"
+ " \"\n"
+ " bar=\" asdf\"\n"
+ " bar= zxcv \n"
+ " foo=asdf\n"
+ " aa=df-bar=()\n"
+ " a-b=df-b\"ar=()\n"
+ " ac=df\"-bar=()\n"
+ " ad=df-bar=()\n"
+ " ></div>\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}