#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^BC\n]*A[^BC\n]*$"
Local $sString = "This is A test for B or C." & @CRLF & _
"This is A test for D or E." & @CRLF & _
"This is Atest for F" & @CRLF & _
"A" & @CRLF & _
"" & @CRLF & _
"BBCCCCa" & @CRLF & _
"BBCCCCA" & @CRLF & _
"bbbbcccA" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")