re = /^[^BC\n]*A[^BC\n]*$/m
str = 'This is A test for B or C.
This is A test for D or E.
This is Atest for F
A
BBCCCCa
BBCCCCA
bbbbcccA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end