import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^BC\\n]*A[^BC\\n]*$";
final String string = "This is A test for B or C.\n"
+ "This is A test for D or E.\n"
+ "This is Atest for F\n"
+ "A\n\n"
+ "BBCCCCa\n"
+ "BBCCCCA\n"
+ "bbbbcccA\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}