using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^BC\n]*A[^BC\n]*$";
string input = @"This is A test for B or C.
This is A test for D or E.
This is Atest for F
A
BBCCCCa
BBCCCCA
bbbbcccA
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}