package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^BC\n]*A[^BC\n]*$`)
var str = `This is A test for B or C.
This is A test for D or E.
This is Atest for F
A
BBCCCCa
BBCCCCA
bbbbcccA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}