#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\\Desktop|Downloads\\)(?<EXE_RAN>.*\.exe)"
Local $sString = "C:\users\user1\Downloads\blah.exe" & @CRLF & _
"C:\Users\user234\Downloads\sqldeveloper-17.4.0.355.2349-x64\sqldeveloper\sqldeveloper\bin\sqldeveloper64W.exe" & @CRLF & _
"C:\Users\user9823\AppData\Local\iManage\Installer\Updates\iManage Work Desktop for Windows x86.exe" & @CRLF & _
"C:\Users\johnsmith\Desktop\dataloader-44.0.0.exe" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")