# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\\Desktop|Downloads\\)(?<EXE_RAN>.*\.exe)"
test_str = ("C:\\users\\user1\\Downloads\\blah.exe\n"
"C:\\Users\\user234\\Downloads\\sqldeveloper-17.4.0.355.2349-x64\\sqldeveloper\\sqldeveloper\\bin\\sqldeveloper64W.exe\n"
"C:\\Users\\user9823\\AppData\\Local\\iManage\\Installer\\Updates\\iManage Work Desktop for Windows x86.exe\n"
"C:\\Users\\johnsmith\\Desktop\\dataloader-44.0.0.exe\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.