import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\Desktop|Downloads\\\\)(?<EXE_RAN>.*\\.exe)";
final String string = "C:\\users\\user1\\Downloads\\blah.exe\n"
+ "C:\\Users\\user234\\Downloads\\sqldeveloper-17.4.0.355.2349-x64\\sqldeveloper\\sqldeveloper\\bin\\sqldeveloper64W.exe\n"
+ "C:\\Users\\user9823\\AppData\\Local\\iManage\\Installer\\Updates\\iManage Work Desktop for Windows x86.exe\n"
+ "C:\\Users\\johnsmith\\Desktop\\dataloader-44.0.0.exe\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}