use strict;
my $str = 'C:\\users\\user1\\Downloads\\blah.exe
C:\\Users\\user234\\Downloads\\sqldeveloper-17.4.0.355.2349-x64\\sqldeveloper\\sqldeveloper\\bin\\sqldeveloper64W.exe
C:\\Users\\user9823\\AppData\\Local\\iManage\\Installer\\Updates\\iManage Work Desktop for Windows x86.exe
C:\\Users\\johnsmith\\Desktop\\dataloader-44.0.0.exe
';
my $regex = qr/(?<=\\Desktop|Downloads\\)(?<EXE_RAN>.*\.exe)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}