#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)something\((.+),(.+)\)"
Local $sString = "something(name_one,name_two)."
Local $sSubst = "something(\2,\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)