import re
regex = re.compile(r"something\((.+),(.+)\)", flags=re.MULTILINE)
test_str = "something(name_one,name_two)."
subst = "something(\\2,\\1)"
result = regex.sub(subst, test_str)
if result:
print(result)