using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"something\((.+),(.+)\)";
string substitution = @"something(\2,\1)";
string input = @"something(name_one,name_two).";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}