// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)something\((.+),(.+)\)").unwrap();
let string = "something(name_one,name_two).";
let substitution = "something(\\2,\\1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}