#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\w*[Aa]\w*[Aa]\w*[Aa]\w*\b"
Local $sString = "Anagram" & @CRLF & _
"Assassination" & @CRLF & _
"Abaca" & @CRLF & _
"Analogy" & @CRLF & _
"Apple" & @CRLF & _
"Bicycle"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")