import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w*[Aa]\\w*[Aa]\\w*[Aa]\\w*\\b";
final String string = "Anagram\n"
+ "Assassination\n"
+ "Abaca\n"
+ "Analogy\n"
+ "Apple\n"
+ "Bicycle";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}