re = /\b\w*[Aa]\w*[Aa]\w*[Aa]\w*\b/m
str = 'Anagram
Assassination
Abaca
Analogy
Apple
Bicycle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end