$re = '/\b\w*[Aa]\w*[Aa]\w*[Aa]\w*\b/m';
$str = 'Anagram
Assassination
Abaca
Analogy
Apple
Bicycle';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);