using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\w*[Aa]\w*[Aa]\w*[Aa]\w*\b";
string input = @"Anagram
Assassination
Abaca
Analogy
Apple
Bicycle";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}