Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(^#[0-9A-Fa-f]{6}$)|(^#[0-9A-Fa-f]{3,4}$)|(^#[0-9A-Fa-f]{8}$)
/
gm
Input 1
1
New
// good case #000 #123 #999 #AAA #aaa #abc #FFF #0000 #9999 #AAAA #aaaa #abcd #FFFF #ffff #000000 #456789 #999999 #AAAAAA #aaaaaa #abcdef #FFFFFF #ffffff #00000000 #12345678 #99999999 #AAAAAAAA #aaaaaaaa #abcdefcc #FFFFFFFF #ffffffff #00123456 //bad case ## #0 #1 #F #f #12 #AB #ae #aaaaa #fffff #aaaah #aaaaaaa #0000000 #ffffhij #h000000 #aaaaaaai #000k0123 #asdfasfa