#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*"
Local $sString = "Abby.O’connor@test.org" & @CRLF & _
"Abby.O'connor@test.org" & @CRLF & _
"AbbyO'&^%@#$connor@test.org" & @CRLF & _
"abbyoconnor@test.org" & @CRLF & _
"abbyoor@te.org" & @CRLF & _
"abb.yoor@t.e.s.rg" & @CRLF & _
"" & @CRLF & _
"abby!oconnor@test.org" & @CRLF & _
"ab#byoconnor@test.org" & @CRLF & _
"abb$yoconnor@test.org" & @CRLF & _
"abb*yoconnor@test.org" & @CRLF & _
"abbyoc-onnor@test.org" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")