import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+([-+.']\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*";
final String string = "Abby.O’connor@test.org\n"
+ "Abby.O'connor@test.org\n"
+ "AbbyO'&^%@#$connor@test.org\n"
+ "abbyoconnor@test.org\n"
+ "abbyoor@te.org\n"
+ "abb.yoor@t.e.s.rg\n\n"
+ "abby!oconnor@test.org\n"
+ "ab#byoconnor@test.org\n"
+ "abb$yoconnor@test.org\n"
+ "abb*yoconnor@test.org\n"
+ "abbyoc-onnor@test.org\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}