package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*`)
var str = `Abby.O’connor@test.org
Abby.O'connor@test.org
AbbyO'&^%@#$connor@test.org
abbyoconnor@test.org
abbyoor@te.org
abb.yoor@t.e.s.rg
abby!oconnor@test.org
ab#byoconnor@test.org
abb$yoconnor@test.org
abb*yoconnor@test.org
abbyoc-onnor@test.org
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}