import re
regex = re.compile(r"\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*", flags=re.MULTILINE)
test_str = ("Abby.O’connor@test.org\n"
"Abby.O'connor@test.org\n"
"AbbyO'&^%@#$connor@test.org\n"
"abbyoconnor@test.org\n"
"abbyoor@te.org\n"
"abb.yoor@t.e.s.rg\n\n"
"abby!oconnor@test.org\n"
"ab#byoconnor@test.org\n"
"abb$yoconnor@test.org\n"
"abb*yoconnor@test.org\n"
"abbyoc-onnor@test.org\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")