using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ACTION\s:\[\d\]\s\'(?<ACTION>[^\']*)\'\s+DATABASE\[\d+\]\s\'(?<DATABASE>[^\']*)\'";
string input = @"ACTION :[7] 'CONNECT'
DATABASE[1] 'SYSTEM'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}