const regex = /ACTION\s:\[\d\]\s\'(?<ACTION>[^\']*)\'\s+DATABASE\[\d+\]\s\'(?<DATABASE>[^\']*)\'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ACTION\\s:\\[\\d\\]\\s\\\'(?<ACTION>[^\\\']*)\\\'\\s+DATABASE\\[\\d+\\]\\s\\\'(?<DATABASE>[^\\\']*)\\\'', 'g')
const str = `ACTION :[7] 'CONNECT'
DATABASE[1] 'SYSTEM'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}