re = /ACTION\s:\[\d\]\s\'(?<ACTION>[^\']*)\'\s+DATABASE\[\d+\]\s\'(?<DATABASE>[^\']*)\'/
str = 'ACTION :[7] \'CONNECT\'
DATABASE[1] \'SYSTEM\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end