import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ACTION\\s:\\[\\d\\]\\s\\'(?<ACTION>[^\\']*)\\'\\s+DATABASE\\[\\d+\\]\\s\\'(?<DATABASE>[^\\']*)\\'";
final String string = "ACTION :[7] 'CONNECT'\n"
+ "DATABASE[1] 'SYSTEM'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}