package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ACTION\s:\[\d\]\s\'(?<ACTION>[^\']*)\'\s+DATABASE\[\d+\]\s\'(?<DATABASE>[^\']*)\'`)
var str = `ACTION :[7] 'CONNECT'
DATABASE[1] 'SYSTEM'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}