#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-3](?:\.\d{1,2})?|4(?:\.(?:[0-4][0-9]|50?)?))$"
Local $sString = "1.00" & @CRLF & _
"1.55" & @CRLF & _
"2.0" & @CRLF & _
"2.9" & @CRLF & _
"3.14" & @CRLF & _
"4.01" & @CRLF & _
"4.49" & @CRLF & _
"4.5" & @CRLF & _
"4.50" & @CRLF & _
"4.51" & @CRLF & _
"5.00" & @CRLF & _
"134.50"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")