import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[1-3](?:\\.\\d{1,2})?|4(?:\\.(?:[0-4][0-9]|50?)?))$";
final String string = "1.00\n"
+ "1.55\n"
+ "2.0\n"
+ "2.9\n"
+ "3.14\n"
+ "4.01\n"
+ "4.49\n"
+ "4.5\n"
+ "4.50\n"
+ "4.51\n"
+ "5.00\n"
+ "134.50";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}