const regex = /^(?:[1-3](?:\.\d{1,2})?|4(?:\.(?:[0-4][0-9]|50?)?))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-3](?:\\.\\d{1,2})?|4(?:\\.(?:[0-4][0-9]|50?)?))$', 'mg')
const str = `1.00
1.55
2.0
2.9
3.14
4.01
4.49
4.5
4.50
4.51
5.00
134.50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}