import re
regex = re.compile(r"^(?:[1-3](?:\.\d{1,2})?|4(?:\.(?:[0-4][0-9]|50?)?))$", flags=re.MULTILINE)
test_str = ("1.00\n"
"1.55\n"
"2.0\n"
"2.9\n"
"3.14\n"
"4.01\n"
"4.49\n"
"4.5\n"
"4.50\n"
"4.51\n"
"5.00\n"
"134.50")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")