re = /^(?:[1-3](?:\.\d{1,2})?|4(?:\.(?:[0-4][0-9]|50?)?))$/m
str = '1.00
1.55
2.0
2.9
3.14
4.01
4.49
4.5
4.50
4.51
5.00
134.50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end