#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=(?<!\.)(?<!\-)(?!^)\d{3}(?:\b|(?:\d{3})+)\b)"
Local $sString = "1234" & @CRLF & _
"123" & @CRLF & _
"1234.123" & @CRLF & _
"1234123" & @CRLF & _
"1234123534" & @CRLF & _
"0.123" & @CRLF & _
"-1234" & @CRLF & _
"-123456"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)