import Foundation
let pattern = #"(?=(?<!\.)(?<!\-)(?!^)\d{3}(?:\b|(?:\d{3})+)\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234
123
1234.123
1234123
1234123534
0.123
-1234
-123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)