const regex = /(?=(?<!\.)(?<!\-)(?!^)\d{3}(?:\b|(?:\d{3})+)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?<!\\.)(?<!\\-)(?!^)\\d{3}(?:\\b|(?:\\d{3})+)\\b)', 'gm')
const str = `1234
123
1234.123
1234123
1234123534
0.123
-1234
-123456`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);