$re = '/(?=(?<!\.)(?<!\-)(?!^)\d{3}(?:\b|(?:\d{3})+)\b)/m';
$str = '1234
123
1234.123
1234123
1234123534
0.123
-1234
-123456';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;